I am built the sample application and everythins worked until I turned on Multi User

When I turned on multi user, I was prompted with the Login form where admin was already filled in.
I entered admin as the password, and the was prompted to change the password which I did. When I clicked Save, I got this error:

No user configured for single user mode, detected key : 10000000-0000-0000-0000-000000000001

Then I am logged out.

Each time I try to login, I am prompted to change the password, and each time I get this error when I try to save the new password.

Hi sfpatterson,

This is the result of going from single user mode to multi user mode, and the browser session is still configured as single user mode (called standalone), however now the multi-user version is expecting a verified user logged in, and sometimes the browser cache causes this issue (only happens when switching from single to multi-user), but once the cache is refreshed, and multi-user is configured, this should not happen anymore.

To verify this is the issue, try the application in an incognito mode, and if it works correctly, this is definately the problem, to fix it in the normal browser mode, generally a ctrl-f5 (full reload of the application site) should fix it for you, another thing is also clearing the cookies for this session should help as well.

It must have been a browser cache issue because the next day I tried it and it works fine now.

That’s great, I am happy it is resolved for you!